summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/mozwer-rust/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /toolkit/crashreporter/mozwer-rust/Cargo.toml
parentInitial commit. (diff)
downloadthunderbird-upstream.tar.xz
thunderbird-upstream.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/crashreporter/mozwer-rust/Cargo.toml')
-rw-r--r--toolkit/crashreporter/mozwer-rust/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolkit/crashreporter/mozwer-rust/Cargo.toml b/toolkit/crashreporter/mozwer-rust/Cargo.toml
new file mode 100644
index 0000000000..6b960d827d
--- /dev/null
+++ b/toolkit/crashreporter/mozwer-rust/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "mozwer_s"
+version = "0.1.0"
+authors = ["Gabriele Svelto <gsvelto@mozilla.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[dependencies]
+libc = "0.2.0"
+mozilla-central-workspace-hack = { path = "../../../build/workspace-hack" }
+rust-ini = "0.10"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = { version = "1.0" }
+uuid = { version = "1.0", features = ["v4"] }
+winapi = "0.3"
+
+[lib]
+name = "mozwer_s"
+crate-type = ["staticlib"]
+path = "lib.rs"