summaryrefslogtreecommitdiffstats
path: root/xpcom/geckoprocesstypes_generator/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /xpcom/geckoprocesstypes_generator/setup.py
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xpcom/geckoprocesstypes_generator/setup.py')
-rw-r--r--xpcom/geckoprocesstypes_generator/setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/xpcom/geckoprocesstypes_generator/setup.py b/xpcom/geckoprocesstypes_generator/setup.py
new file mode 100644
index 0000000000..9fd8dff82d
--- /dev/null
+++ b/xpcom/geckoprocesstypes_generator/setup.py
@@ -0,0 +1,17 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+setup(
+ name="geckoprocesstypes",
+ version="1.0",
+ description="Generator for GeckoProcessTypes related resources.",
+ author="Mozilla Foundation",
+ license="MPL 2.0",
+ packages=find_packages(),
+ install_requires=[],
+ entry_points={"console_scripts": ["GeckoProcessTypes.py = geckoprocesstypes:main"]},
+ keywords=["geckoprocesstypes"],
+)