summaryrefslogtreecommitdiffstats
path: root/xpcom/idl-parser/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:32:43 +0000
commit6bf0a5cb5034a7e684dcc3500e841785237ce2dd (patch)
treea68f146d7fa01f0134297619fbe7e33db084e0aa /xpcom/idl-parser/setup.py
parentInitial commit. (diff)
downloadthunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.tar.xz
thunderbird-6bf0a5cb5034a7e684dcc3500e841785237ce2dd.zip
Adding upstream version 1:115.7.0.upstream/1%115.7.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'xpcom/idl-parser/setup.py')
-rw-r--r--xpcom/idl-parser/setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/xpcom/idl-parser/setup.py b/xpcom/idl-parser/setup.py
new file mode 100644
index 0000000000..af6b417cb7
--- /dev/null
+++ b/xpcom/idl-parser/setup.py
@@ -0,0 +1,18 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+setup(
+ name="xpidl",
+ version="1.0",
+ description="Parser and header generator for xpidl files.",
+ author="Mozilla Foundation",
+ license="MPL 2.0",
+ packages=find_packages(),
+ install_requires=["ply>=3.6,<4.0"],
+ url="https://github.com/pelmers/xpidl",
+ entry_points={"console_scripts": ["header.py = xpidl.header:main"]},
+ keywords=["xpidl", "parser"],
+)