summaryrefslogtreecommitdiffstats
path: root/browser/components/customizableui/test/browser_customizemode_lwthemes.js
diff options
context:
space:
mode:
Diffstat (limited to 'browser/components/customizableui/test/browser_customizemode_lwthemes.js')
-rw-r--r--browser/components/customizableui/test/browser_customizemode_lwthemes.js25
1 files changed, 25 insertions, 0 deletions
diff --git a/browser/components/customizableui/test/browser_customizemode_lwthemes.js b/browser/components/customizableui/test/browser_customizemode_lwthemes.js
new file mode 100644
index 0000000000..3b19566ac0
--- /dev/null
+++ b/browser/components/customizableui/test/browser_customizemode_lwthemes.js
@@ -0,0 +1,25 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+"use strict";
+
+add_task(async function () {
+ await startCustomizing();
+ // Find the footer buttons to test.
+ let manageLink = document.querySelector("#customization-lwtheme-link");
+
+ let waitForNewTab = BrowserTestUtils.waitForNewTab(gBrowser, "about:addons");
+ manageLink.click();
+ let addonsTab = await waitForNewTab;
+
+ is(gBrowser.currentURI.spec, "about:addons", "Manage opened about:addons");
+ BrowserTestUtils.removeTab(addonsTab);
+
+ // Wait for customize mode to be re-entered now that the customize tab is
+ // active. This is needed for endCustomizing() to work properly.
+ await TestUtils.waitForCondition(
+ () => document.documentElement.getAttribute("customizing") == "true"
+ );
+ await endCustomizing();
+});