summaryrefslogtreecommitdiffstats
path: root/browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js
diff options
context:
space:
mode:
Diffstat (limited to 'browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js')
-rw-r--r--browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js37
1 files changed, 37 insertions, 0 deletions
diff --git a/browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js b/browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js
new file mode 100644
index 0000000000..d330625bbb
--- /dev/null
+++ b/browser/components/urlbar/tests/unit/test_escaping_badEscapedURI.js
@@ -0,0 +1,37 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+/**
+ * Test bug 422277 to make sure bad escaped uris don't get escaped. This makes
+ * sure we don't hit an assertion for "not a UTF8 string".
+ */
+
+testEngine_setup();
+
+add_task(async function test() {
+ Services.prefs.setBoolPref("browser.urlbar.autoFill", false);
+ Services.prefs.setBoolPref("browser.urlbar.suggest.searches", false);
+ registerCleanupFunction(() => {
+ Services.prefs.clearUserPref("browser.urlbar.suggest.searches");
+ });
+
+ info("Bad escaped uri stays escaped");
+ let uri1 = Services.io.newURI("http://site/%EAid");
+ await PlacesTestUtils.addVisits([{ uri: uri1, title: "title" }]);
+ let context = createContext("site", { isPrivate: false });
+ await check_results({
+ context,
+ matches: [
+ makeSearchResult(context, {
+ engineName: SUGGESTIONS_ENGINE_NAME,
+ heuristic: true,
+ }),
+ makeVisitResult(context, {
+ uri: uri1.spec,
+ title: "title",
+ }),
+ ],
+ });
+ await cleanupPlaces();
+});