summaryrefslogtreecommitdiffstats
path: root/browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js
diff options
context:
space:
mode:
Diffstat (limited to 'browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js')
-rw-r--r--browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js42
1 files changed, 42 insertions, 0 deletions
diff --git a/browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js b/browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js
new file mode 100644
index 0000000000..98d12ebe32
--- /dev/null
+++ b/browser/components/urlbar/tests/unit/test_tags_matchBookmarkTitles.js
@@ -0,0 +1,42 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+/*
+ * Test bug 416211 to make sure results that match the tag show the bookmark
+ * title instead of the page title.
+ */
+
+testEngine_setup();
+
+add_task(async function test_tag_match_has_bookmark_title() {
+ Services.prefs.setBoolPref("browser.urlbar.suggest.searches", false);
+ registerCleanupFunction(() => {
+ Services.prefs.clearUserPref("browser.urlbar.suggest.searches");
+ });
+
+ info("Make sure the tag match gives the bookmark title");
+ let uri = Services.io.newURI("http://theuri/");
+ await PlacesTestUtils.addVisits({ uri, title: "Page title" });
+ await PlacesTestUtils.addBookmarkWithDetails({
+ uri,
+ title: "Bookmark title",
+ tags: ["superTag"],
+ });
+ let context = createContext("superTag", { isPrivate: false });
+ await check_results({
+ context,
+ matches: [
+ makeSearchResult(context, {
+ engineName: SUGGESTIONS_ENGINE_NAME,
+ heuristic: true,
+ }),
+ makeBookmarkResult(context, {
+ uri: uri.spec,
+ title: "Bookmark title",
+ tags: ["superTag"],
+ }),
+ ],
+ });
+ await cleanupPlaces();
+});