summaryrefslogtreecommitdiffstats
path: root/browser/installer/linux/app/debian
diff options
context:
space:
mode:
Diffstat (limited to 'browser/installer/linux/app/debian')
-rw-r--r--browser/installer/linux/app/debian/changelog.in5
-rw-r--r--browser/installer/linux/app/debian/compat1
-rw-r--r--browser/installer/linux/app/debian/control.in10
-rw-r--r--browser/installer/linux/app/debian/install.in2
-rw-r--r--browser/installer/linux/app/debian/links.in6
-rw-r--r--browser/installer/linux/app/debian/rules7
6 files changed, 31 insertions, 0 deletions
diff --git a/browser/installer/linux/app/debian/changelog.in b/browser/installer/linux/app/debian/changelog.in
new file mode 100644
index 0000000000..aaf92817c9
--- /dev/null
+++ b/browser/installer/linux/app/debian/changelog.in
@@ -0,0 +1,5 @@
+${DEB_PKG_NAME} (${DEB_PKG_VERSION}) UNRELEASED; urgency=medium
+
+ * N/A
+
+ -- Mozilla Releng <release@mozilla.com> ${DEB_CHANGELOG_DATE}
diff --git a/browser/installer/linux/app/debian/compat b/browser/installer/linux/app/debian/compat
new file mode 100644
index 0000000000..ec635144f6
--- /dev/null
+++ b/browser/installer/linux/app/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/browser/installer/linux/app/debian/control.in b/browser/installer/linux/app/debian/control.in
new file mode 100644
index 0000000000..7d758bf3f3
--- /dev/null
+++ b/browser/installer/linux/app/debian/control.in
@@ -0,0 +1,10 @@
+Source: ${DEB_PKG_NAME}
+Maintainer: Mozilla Releng <release@mozilla.com>
+Priority: optional
+Section: web
+Build-Depends: debhelper (>= 9)
+
+Package: ${DEB_PKG_NAME}
+Architecture: ${DEB_ARCH_NAME}
+Depends: ${DEB_DEPENDS}
+Description: ${DEB_DESCRIPTION}
diff --git a/browser/installer/linux/app/debian/install.in b/browser/installer/linux/app/debian/install.in
new file mode 100644
index 0000000000..69f20af85e
--- /dev/null
+++ b/browser/installer/linux/app/debian/install.in
@@ -0,0 +1,2 @@
+firefox/* ${DEB_PKG_INSTALL_PATH}
+debian/${DEB_PKG_NAME}.desktop usr/share/applications
diff --git a/browser/installer/linux/app/debian/links.in b/browser/installer/linux/app/debian/links.in
new file mode 100644
index 0000000000..c79416e105
--- /dev/null
+++ b/browser/installer/linux/app/debian/links.in
@@ -0,0 +1,6 @@
+${DEB_PKG_INSTALL_PATH}/firefox usr/bin/${DEB_PKG_NAME}
+${DEB_PKG_INSTALL_PATH}/browser/chrome/icons/default/default16.png usr/share/icons/hicolor/16x16/apps/${DEB_PKG_NAME}.png
+${DEB_PKG_INSTALL_PATH}/browser/chrome/icons/default/default32.png usr/share/icons/hicolor/32x32/apps/${DEB_PKG_NAME}.png
+${DEB_PKG_INSTALL_PATH}/browser/chrome/icons/default/default48.png usr/share/icons/hicolor/48x48/apps/${DEB_PKG_NAME}.png
+${DEB_PKG_INSTALL_PATH}/browser/chrome/icons/default/default64.png usr/share/icons/hicolor/64x64/apps/${DEB_PKG_NAME}.png
+${DEB_PKG_INSTALL_PATH}/browser/chrome/icons/default/default128.png usr/share/icons/hicolor/128x128/apps/${DEB_PKG_NAME}.png
diff --git a/browser/installer/linux/app/debian/rules b/browser/installer/linux/app/debian/rules
new file mode 100644
index 0000000000..db56a808cc
--- /dev/null
+++ b/browser/installer/linux/app/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+override_dh_strip_nondeterminism:
+ dh_strip_nondeterminism -Xxpi