summaryrefslogtreecommitdiffstats
path: root/comm/mail/branding/thunderbird/locales
diff options
context:
space:
mode:
Diffstat (limited to 'comm/mail/branding/thunderbird/locales')
-rw-r--r--comm/mail/branding/thunderbird/locales/Makefile.in8
-rw-r--r--comm/mail/branding/thunderbird/locales/en-US/brand.dtd13
-rw-r--r--comm/mail/branding/thunderbird/locales/en-US/brand.ftl21
-rw-r--r--comm/mail/branding/thunderbird/locales/en-US/brand.properties7
-rwxr-xr-xcomm/mail/branding/thunderbird/locales/jar.mn12
-rw-r--r--comm/mail/branding/thunderbird/locales/moz.build6
6 files changed, 67 insertions, 0 deletions
diff --git a/comm/mail/branding/thunderbird/locales/Makefile.in b/comm/mail/branding/thunderbird/locales/Makefile.in
new file mode 100644
index 0000000000..c0fdaa9993
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/Makefile.in
@@ -0,0 +1,8 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+LOCALE_TOPDIR=$(commtopsrcdir)
+LOCALE_RELATIVEDIR=mail/branding/thunderbird/locales
+
+include $(topsrcdir)/config/config.mk
diff --git a/comm/mail/branding/thunderbird/locales/en-US/brand.dtd b/comm/mail/branding/thunderbird/locales/en-US/brand.dtd
new file mode 100644
index 0000000000..0ed7d84857
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/en-US/brand.dtd
@@ -0,0 +1,13 @@
+<!-- This Source Code Form is subject to the terms of the Mozilla Public
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+<!ENTITY brandShortName "Thunderbird">
+<!ENTITY brandShorterName "Thunderbird">
+<!ENTITY brandFullName "Mozilla Thunderbird">
+<!-- LOCALIZATION NOTE (brandProductName):
+ This brand name can be used in messages where the product name needs to
+ remain unchanged across different versions (Daily, Beta, etc.). -->
+<!ENTITY brandProductName "Thunderbird">
+<!ENTITY vendorShortName "Mozilla">
+<!ENTITY trademarkInfo.part1 "Mozilla Thunderbird and the Thunderbird logos
+ are trademarks of the Mozilla Foundation.">
diff --git a/comm/mail/branding/thunderbird/locales/en-US/brand.ftl b/comm/mail/branding/thunderbird/locales/en-US/brand.ftl
new file mode 100644
index 0000000000..1c3a9fc7c1
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/en-US/brand.ftl
@@ -0,0 +1,21 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+## Thunderbird Brand
+##
+## Thunderbird must be treated as a brand, and kept in English.
+## It cannot be:
+## - Transliterated.
+## - Translated.
+##
+## Reference: https://www.mozilla.org/styleguide/communications/translation/
+
+-brand-shorter-name = Thunderbird
+-brand-short-name = Thunderbird
+-brand-full-name = Mozilla Thunderbird
+# This brand name can be used in messages where the product name needs to
+# remain unchanged across different versions (Daily, Beta, etc.).
+-brand-product-name = Thunderbird
+-vendor-short-name = Mozilla
+trademarkInfo = Mozilla Thunderbird and the Thunderbird logos are trademarks of the Mozilla Foundation.
diff --git a/comm/mail/branding/thunderbird/locales/en-US/brand.properties b/comm/mail/branding/thunderbird/locales/en-US/brand.properties
new file mode 100644
index 0000000000..9dd5011219
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/en-US/brand.properties
@@ -0,0 +1,7 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+brandShortName=Thunderbird
+brandShorterName=Thunderbird
+brandFullName=Mozilla Thunderbird
+vendorShortName=Mozilla
diff --git a/comm/mail/branding/thunderbird/locales/jar.mn b/comm/mail/branding/thunderbird/locales/jar.mn
new file mode 100755
index 0000000000..601859210b
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/jar.mn
@@ -0,0 +1,12 @@
+#filter substitution
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+[localization] @AB_CD@.jar:
+ branding (%*.ftl)
+
+@AB_CD@.jar:
+% locale branding @AB_CD@ %locale/branding/
+ locale/branding/brand.dtd (%brand.dtd)
+ locale/branding/brand.properties (%brand.properties)
diff --git a/comm/mail/branding/thunderbird/locales/moz.build b/comm/mail/branding/thunderbird/locales/moz.build
new file mode 100644
index 0000000000..de5cd1bf81
--- /dev/null
+++ b/comm/mail/branding/thunderbird/locales/moz.build
@@ -0,0 +1,6 @@
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+JAR_MANIFESTS += ["jar.mn"]