summaryrefslogtreecommitdiffstats
path: root/comm/mailnews/local/src/Pop3ProtocolHandler.jsm
diff options
context:
space:
mode:
Diffstat (limited to 'comm/mailnews/local/src/Pop3ProtocolHandler.jsm')
-rw-r--r--comm/mailnews/local/src/Pop3ProtocolHandler.jsm40
1 files changed, 40 insertions, 0 deletions
diff --git a/comm/mailnews/local/src/Pop3ProtocolHandler.jsm b/comm/mailnews/local/src/Pop3ProtocolHandler.jsm
new file mode 100644
index 0000000000..51b1d5bf22
--- /dev/null
+++ b/comm/mailnews/local/src/Pop3ProtocolHandler.jsm
@@ -0,0 +1,40 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+var EXPORTED_SYMBOLS = ["Pop3ProtocolHandler"];
+
+var { Pop3Channel } = ChromeUtils.import("resource:///modules/Pop3Channel.jsm");
+
+/**
+ * @implements {nsIProtocolHandler}
+ */
+class Pop3ProtocolHandler {
+ QueryInterface = ChromeUtils.generateQI(["nsIProtocolHandler"]);
+
+ scheme = "pop3";
+
+ newChannel(uri, loadInfo) {
+ let channel = new Pop3Channel(uri, loadInfo);
+ let spec = uri.spec;
+ if (
+ spec.includes("part=") &&
+ !spec.includes("type=message/rfc822") &&
+ !spec.includes("type=application/x-message-display") &&
+ !spec.includes("type=application/pdf")
+ ) {
+ channel.contentDisposition = Ci.nsIChannel.DISPOSITION_ATTACHMENT;
+ } else {
+ channel.contentDisposition = Ci.nsIChannel.DISPOSITION_INLINE;
+ }
+ return channel;
+ }
+
+ allowPort(port, scheme) {
+ return true;
+ }
+}
+
+Pop3ProtocolHandler.prototype.classID = Components.ID(
+ "{eed38573-d01b-4c13-9f9d-f69963095a4d}"
+);