summaryrefslogtreecommitdiffstats
path: root/comm/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'comm/pyproject.toml')
-rw-r--r--comm/pyproject.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/comm/pyproject.toml b/comm/pyproject.toml
new file mode 100644
index 0000000000..6d5fd94695
--- /dev/null
+++ b/comm/pyproject.toml
@@ -0,0 +1,48 @@
+[tool.ruff]
+line-length = 99
+# See https://beta.ruff.rs/docs/rules/ for a full list of rules.
+select = [
+ "E", "W", # pycodestyle
+ "F", # pyflakes
+ "I", # isort
+]
+ignore = [
+ # These should be triaged and either fixed or moved to the list below.
+ "W605",
+
+ # These are intentionally ignored (not necessarily for good reason).
+ "E741",
+
+ # These are handled by black.
+ "E1", "E4", "E5", "W2", "W5"
+]
+exclude = [
+ "python/l10n/tb_fluent_migrations"
+]
+builtins = ["gdb"]
+
+[tool.ruff.per-file-ignores]
+
+[tool.ruff.isort]
+known-first-party = [
+ "mach",
+ "mozboot",
+ "mozbuild",
+ "mozpack",
+ "mozharness",
+ "mozlint",
+ "mozperftest",
+ "mozrelease",
+ "mozterm",
+ "mozversioncontrol",
+ "mozxchannel",
+ "tbxchannel",
+ "gecko_taskgraph",
+ "buildconfig",
+]
+known-local-folder = [
+ "rocboot",
+ "rocbuild",
+ "thirdroc",
+ "comm_taskgraph",
+]