summaryrefslogtreecommitdiffstats
path: root/comm/python/thirdroc/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'comm/python/thirdroc/setup.py')
-rw-r--r--comm/python/thirdroc/setup.py24
1 files changed, 24 insertions, 0 deletions
diff --git a/comm/python/thirdroc/setup.py b/comm/python/thirdroc/setup.py
new file mode 100644
index 0000000000..2a4cf6d3b5
--- /dev/null
+++ b/comm/python/thirdroc/setup.py
@@ -0,0 +1,24 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+VERSION = "0.1"
+
+setup(
+ author="MZLA Technologies",
+ author_email="MZLA Technologies Release Engineering",
+ name="thirdroc",
+ description="Utility for maintaining third party source code in Thunderbird",
+ license="MPL 2.0",
+ packages=find_packages(),
+ version=VERSION,
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Software Development :: Build Tools",
+ "License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+)