summaryrefslogtreecommitdiffstats
path: root/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info
diff options
context:
space:
mode:
Diffstat (limited to 'comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info')
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/PKG-INFO61
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/SOURCES.txt24
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/dependency_links.txt1
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/entry_points.txt3
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/requires.txt6
-rw-r--r--comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/top_level.txt1
6 files changed, 96 insertions, 0 deletions
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/PKG-INFO b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/PKG-INFO
new file mode 100644
index 0000000000..a717c518eb
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/PKG-INFO
@@ -0,0 +1,61 @@
+Metadata-Version: 2.1
+Name: fluent.migratetb
+Version: 0.11.2
+Summary: Toolchain to migrate legacy translation to Fluent. (Thunderbird fork)
+Home-page: https://github.com/jfx2006/tb-fluent-migrate/
+Author: Mozilla
+Author-email: l10n-drivers@mozilla.org
+License: APL 2
+Keywords: fluent,localization,l10n
+Classifier: Development Status :: 3 - Alpha
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: Apache Software License
+Classifier: Programming Language :: Python :: 3.7
+Description-Content-Type: text/markdown
+Provides-Extra: hg
+License-File: LICENSE
+
+# Fluent Migration Tools - Thunderbird Fork
+
+Programmatically create Fluent files from existing content in both legacy
+and Fluent formats. Use recipes written in Python to migrate content for each
+of your localizations.
+
+This is a fork for performing Thunderbird string migrations. Usage is slightly
+different than upsteam due to the use of a monorepo.
+
+`migrate-l10n` is a CLI script which uses the `fluent.migrate` module under
+the hood to run migrations on existing translations.
+
+`validate-l10n-recipe` is a CLI script to test a migration recipe for common
+errors, without trying to apply it.
+
+Installation
+------------
+
+- Clone this repo somewhere
+
+- pip install "<path-to->/tb-fluent-migrate[hg]"
+
+Alternatively, install right from the repo:
+
+- pip install "fluent.migrate[hg] @ git+https://github.com/jfx2006/tb-fluent-migrate"
+
+
+Usage
+-----
+
+Migrations consist of _recipes_, which are applied to a _localization repository_, based on _template files_.
+You can find recipes for Thunderbird in `comm-central/python/l10n/tb_fluent_migrations/`,
+the reference repository is [comm-strings-quarantine](https://hg.mozilla.org/projects/comm-strings-quarantine/) or _quarantine_.
+You apply those migrations to l10n repositories in [comm-l10n](https://hg.mozilla.org/projects/comm-l10n/).
+
+The migrations are run as python modules, so you need to have their file location in `PYTHONPATH`.
+
+An example would look like
+
+ $ migrate-l10n --locale it --reference-dir comm-strings-quarantine --localization-dir comm-l10n bug_1802387_langpack_defines
+
+Upstream
+--------
+https://hg.mozilla.org/l10n/fluent-migration/
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/SOURCES.txt b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/SOURCES.txt
new file mode 100644
index 0000000000..075b179bd3
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/SOURCES.txt
@@ -0,0 +1,24 @@
+LICENSE
+README.md
+setup.cfg
+setup.py
+fluent/__init__.py
+fluent.migratetb.egg-info/PKG-INFO
+fluent.migratetb.egg-info/SOURCES.txt
+fluent.migratetb.egg-info/dependency_links.txt
+fluent.migratetb.egg-info/entry_points.txt
+fluent.migratetb.egg-info/requires.txt
+fluent.migratetb.egg-info/top_level.txt
+fluent/migratetb/__init__.py
+fluent/migratetb/_context.py
+fluent/migratetb/blame.py
+fluent/migratetb/changesets.py
+fluent/migratetb/context.py
+fluent/migratetb/errors.py
+fluent/migratetb/evaluator.py
+fluent/migratetb/helpers.py
+fluent/migratetb/merge.py
+fluent/migratetb/tool.py
+fluent/migratetb/transforms.py
+fluent/migratetb/util.py
+fluent/migratetb/validator.py \ No newline at end of file
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/dependency_links.txt b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/dependency_links.txt
new file mode 100644
index 0000000000..8b13789179
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/entry_points.txt b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/entry_points.txt
new file mode 100644
index 0000000000..ad6c985e8f
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/entry_points.txt
@@ -0,0 +1,3 @@
+[console_scripts]
+migrate-l10n-tb = fluent.migratetb.tool:cli
+validate-l10n-tb-recipe = fluent.migratetb.validator:cli
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/requires.txt b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/requires.txt
new file mode 100644
index 0000000000..84a38c8fe2
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/requires.txt
@@ -0,0 +1,6 @@
+compare-locales<9.0,>=8.1
+fluent.syntax<0.19,>=0.18.0
+six
+
+[hg]
+python-hglib
diff --git a/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/top_level.txt b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/top_level.txt
new file mode 100644
index 0000000000..a3582d405a
--- /dev/null
+++ b/comm/third_party/python/fluent.migratetb/fluent.migratetb.egg-info/top_level.txt
@@ -0,0 +1 @@
+fluent