summaryrefslogtreecommitdiffstats
path: root/devtools/client/netmonitor/test/node/reducers/sort.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'devtools/client/netmonitor/test/node/reducers/sort.spec.js')
-rw-r--r--devtools/client/netmonitor/test/node/reducers/sort.spec.js28
1 files changed, 28 insertions, 0 deletions
diff --git a/devtools/client/netmonitor/test/node/reducers/sort.spec.js b/devtools/client/netmonitor/test/node/reducers/sort.spec.js
new file mode 100644
index 0000000000..4afd7c0fe3
--- /dev/null
+++ b/devtools/client/netmonitor/test/node/reducers/sort.spec.js
@@ -0,0 +1,28 @@
+/* Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/ */
+
+"use strict";
+
+const {
+ Sort,
+ sortReducer,
+} = require("resource://devtools/client/netmonitor/src/reducers/sort.js");
+const {
+ SORT_BY,
+} = require("resource://devtools/client/netmonitor/src/constants.js");
+
+describe("sorting reducer", () => {
+ it("it should sort by sort type", () => {
+ const initialState = new Sort();
+ const action = {
+ type: SORT_BY,
+ sortType: "TimeWhen",
+ };
+ const expectedState = {
+ type: "TimeWhen",
+ ascending: true,
+ };
+
+ expect(expectedState).toEqual(sortReducer(initialState, action));
+ });
+});