summaryrefslogtreecommitdiffstats
path: root/dom/webidl/PromiseRejectionEvent.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/PromiseRejectionEvent.webidl')
-rw-r--r--dom/webidl/PromiseRejectionEvent.webidl23
1 files changed, 23 insertions, 0 deletions
diff --git a/dom/webidl/PromiseRejectionEvent.webidl b/dom/webidl/PromiseRejectionEvent.webidl
new file mode 100644
index 0000000000..df027e909e
--- /dev/null
+++ b/dom/webidl/PromiseRejectionEvent.webidl
@@ -0,0 +1,23 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/webappapis.html#the-promiserejectionevent-interface
+ */
+
+[Exposed=(Window,Worker)]
+interface PromiseRejectionEvent : Event
+{
+ constructor(DOMString type, PromiseRejectionEventInit eventInitDict);
+
+ [BinaryName="rejectedPromise"]
+ readonly attribute Promise<any> promise;
+ readonly attribute any reason;
+};
+
+dictionary PromiseRejectionEventInit : EventInit {
+ required Promise<any> promise;
+ any reason;
+};