summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ReadableByteStreamController.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/ReadableByteStreamController.webidl')
-rw-r--r--dom/webidl/ReadableByteStreamController.webidl25
1 files changed, 25 insertions, 0 deletions
diff --git a/dom/webidl/ReadableByteStreamController.webidl b/dom/webidl/ReadableByteStreamController.webidl
new file mode 100644
index 0000000000..74dbfc4c4b
--- /dev/null
+++ b/dom/webidl/ReadableByteStreamController.webidl
@@ -0,0 +1,25 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#rbs-controller-class-definition
+ */
+
+[Exposed=*]
+interface ReadableByteStreamController {
+ [Throws] // Throws on OOM
+ readonly attribute ReadableStreamBYOBRequest? byobRequest;
+
+ readonly attribute unrestricted double? desiredSize;
+
+ [Throws]
+ undefined close();
+
+ [Throws]
+ undefined enqueue(ArrayBufferView chunk);
+
+ [Throws]
+ undefined error(optional any e);
+};