summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ShadowRoot.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/ShadowRoot.webidl')
-rw-r--r--dom/webidl/ShadowRoot.webidl60
1 files changed, 60 insertions, 0 deletions
diff --git a/dom/webidl/ShadowRoot.webidl b/dom/webidl/ShadowRoot.webidl
new file mode 100644
index 0000000000..372c5e5919
--- /dev/null
+++ b/dom/webidl/ShadowRoot.webidl
@@ -0,0 +1,60 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dvcs.w3.org/hg/webcomponents/raw-file/tip/spec/shadow/index.html
+ *
+ * Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
+ * liability, trademark and document use rules apply.
+ */
+
+// https://dom.spec.whatwg.org/#enumdef-shadowrootmode
+enum ShadowRootMode {
+ "open",
+ "closed"
+};
+
+enum SlotAssignmentMode { "manual", "named" };
+
+// https://dom.spec.whatwg.org/#shadowroot
+[Exposed=Window]
+interface ShadowRoot : DocumentFragment
+{
+ // Shadow DOM v1
+ readonly attribute ShadowRootMode mode;
+ [Pref="dom.shadowdom.delegatesFocus.enabled"]
+ readonly attribute boolean delegatesFocus;
+ [Pref="dom.shadowdom.slot.assign.enabled"]
+ readonly attribute SlotAssignmentMode slotAssignment;
+ readonly attribute Element host;
+ attribute EventHandler onslotchange;
+
+ Element? getElementById(DOMString elementId);
+
+ // https://w3c.github.io/DOM-Parsing/#the-innerhtml-mixin
+ [CEReactions, SetterThrows]
+ attribute [LegacyNullToEmptyString] DOMString innerHTML;
+
+ // When JS invokes importNode or createElement, the binding code needs to
+ // create a reflector, and so invoking those methods directly on the content
+ // document would cause the reflector to be created in the content scope,
+ // at which point it would be difficult to move into the UA Widget scope.
+ // As such, these methods allow UA widget code to simultaneously create nodes
+ // and associate them with the UA widget tree, so that the reflectors get
+ // created in the right scope.
+ [CEReactions, Throws, Func="IsChromeOrUAWidget"]
+ Node importNodeAndAppendChildAt(Node parentNode, Node node, optional boolean deep = false);
+
+ [CEReactions, Throws, Func="IsChromeOrUAWidget"]
+ Node createElementAndAppendChildAt(Node parentNode, DOMString localName);
+
+ // For triggering UA Widget scope in tests.
+ [ChromeOnly]
+ undefined setIsUAWidget();
+ [ChromeOnly]
+ boolean isUAWidget();
+};
+
+ShadowRoot includes DocumentOrShadowRoot;