summaryrefslogtreecommitdiffstats
path: root/dom/webidl/StaticRange.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/StaticRange.webidl')
-rw-r--r--dom/webidl/StaticRange.webidl25
1 files changed, 25 insertions, 0 deletions
diff --git a/dom/webidl/StaticRange.webidl b/dom/webidl/StaticRange.webidl
new file mode 100644
index 0000000000..be4e702389
--- /dev/null
+++ b/dom/webidl/StaticRange.webidl
@@ -0,0 +1,25 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#staticrange
+ *
+ * Copyright 2012 W3C (MIT, ERCIM, Keio), All Rights Reserved. W3C
+ * liability, trademark and document use rules apply.
+ */
+
+[Exposed=Window]
+interface StaticRange : AbstractRange {
+ [Throws]
+ constructor(StaticRangeInit init);
+ // And no additional functions/properties.
+};
+
+dictionary StaticRangeInit {
+ required Node startContainer;
+ required unsigned long startOffset;
+ required Node endContainer;
+ required unsigned long endOffset;
+};