summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TestUtils.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TestUtils.webidl')
-rw-r--r--dom/webidl/TestUtils.webidl14
1 files changed, 14 insertions, 0 deletions
diff --git a/dom/webidl/TestUtils.webidl b/dom/webidl/TestUtils.webidl
new file mode 100644
index 0000000000..8ba99edbc9
--- /dev/null
+++ b/dom/webidl/TestUtils.webidl
@@ -0,0 +1,14 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://testutils.spec.whatwg.org/#the-testutils-namespace
+ */
+
+[Exposed=(Window,Worker),
+ Pref="dom.testing.testutils.enabled"]
+namespace TestUtils {
+ [NewObject, Throws] Promise<undefined> gc();
+};