summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TransformStreamDefaultController.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TransformStreamDefaultController.webidl')
-rw-r--r--dom/webidl/TransformStreamDefaultController.webidl16
1 files changed, 16 insertions, 0 deletions
diff --git a/dom/webidl/TransformStreamDefaultController.webidl b/dom/webidl/TransformStreamDefaultController.webidl
new file mode 100644
index 0000000000..d7808672aa
--- /dev/null
+++ b/dom/webidl/TransformStreamDefaultController.webidl
@@ -0,0 +1,16 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#ts-default-controller-class-definition
+ */
+
+[Exposed=*]
+interface TransformStreamDefaultController {
+ readonly attribute unrestricted double? desiredSize;
+ [Throws] undefined enqueue(optional any chunk);
+ [Throws] undefined error(optional any reason);
+ [Throws] undefined terminate();
+};