summaryrefslogtreecommitdiffstats
path: root/dom/webidl/UnderlyingSink.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/UnderlyingSink.webidl')
-rw-r--r--dom/webidl/UnderlyingSink.webidl22
1 files changed, 22 insertions, 0 deletions
diff --git a/dom/webidl/UnderlyingSink.webidl b/dom/webidl/UnderlyingSink.webidl
new file mode 100644
index 0000000000..6207589344
--- /dev/null
+++ b/dom/webidl/UnderlyingSink.webidl
@@ -0,0 +1,22 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#underlying-sink-api
+ */
+
+[GenerateInit]
+dictionary UnderlyingSink {
+ UnderlyingSinkStartCallback start;
+ UnderlyingSinkWriteCallback write;
+ UnderlyingSinkCloseCallback close;
+ UnderlyingSinkAbortCallback abort;
+ any type;
+};
+
+callback UnderlyingSinkStartCallback = any (WritableStreamDefaultController controller);
+callback UnderlyingSinkWriteCallback = Promise<undefined> (any chunk, WritableStreamDefaultController controller);
+callback UnderlyingSinkCloseCallback = Promise<undefined> ();
+callback UnderlyingSinkAbortCallback = Promise<undefined> (optional any reason);