summaryrefslogtreecommitdiffstats
path: root/mobile/locales/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'mobile/locales/Makefile.in')
-rw-r--r--mobile/locales/Makefile.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/mobile/locales/Makefile.in b/mobile/locales/Makefile.in
new file mode 100644
index 0000000000..9d5cf767d1
--- /dev/null
+++ b/mobile/locales/Makefile.in
@@ -0,0 +1,30 @@
+# -*- makefile -*-
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/config.mk
+
+USE_AUTOTARGETS_MK=1
+include $(topsrcdir)/config/makefiles/makeutils.mk
+
+$(call errorIfEmpty,MOZ_BRANDING_DIRECTORY)
+SUBMAKEFILES += \
+ $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/Makefile \
+ $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales/Makefile \
+ $(NULL)
+
+include $(topsrcdir)/config/rules.mk
+
+l10n-%: AB_CD=$*
+l10n-%:
+ $(NSINSTALL) -D $(DIST)/install
+ @$(MAKE) -C $(DEPTH)/toolkit/locales l10n-$*
+ @$(MAKE) l10n AB_CD=$* XPI_NAME=locale-$* PREF_DIR=defaults/pref
+ @$(MAKE) -C $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales AB_CD=$* XPI_NAME=locale-$*
+
+# Tailored target to just add the chrome processing for multi-locale builds
+chrome-%: AB_CD=$*
+chrome-%:
+ @$(MAKE) chrome AB_CD=$*
+ @$(MAKE) -C $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales chrome AB_CD=$*