summaryrefslogtreecommitdiffstats
path: root/netwerk/protocol/http/oblivious_http/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'netwerk/protocol/http/oblivious_http/Cargo.toml')
-rw-r--r--netwerk/protocol/http/oblivious_http/Cargo.toml11
1 files changed, 11 insertions, 0 deletions
diff --git a/netwerk/protocol/http/oblivious_http/Cargo.toml b/netwerk/protocol/http/oblivious_http/Cargo.toml
new file mode 100644
index 0000000000..e15cd2f74f
--- /dev/null
+++ b/netwerk/protocol/http/oblivious_http/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "oblivious_http"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+nserror = { path = "../../../../xpcom/rust/nserror" }
+ohttp = { version = "0.3", default-features = false, features = ["gecko", "nss", "client", "server"] }
+rand = "0.8"
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+xpcom = { path = "../../../../xpcom/rust/xpcom" }