summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html')
-rw-r--r--testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html b/testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html
new file mode 100644
index 0000000000..3a1b93f735
--- /dev/null
+++ b/testing/web-platform/tests/console/console-string-format-specifier-symbol-manual.html
@@ -0,0 +1,23 @@
+<!DOCTYPE html>
+<html>
+<head>
+<title>Console String Format Specifier on Symbols</title>
+<meta name="author" title="Dominic Farolino" href="mailto:domfarolino@gmail.com">
+<meta name="assert" content="Console format specifiers on Symbols">
+<link rel="help" href="https://console.spec.whatwg.org/#formatter">
+</head>
+<body>
+<p>Open the console inside the developer tools. It should contain five entries, each of which are:</p>
+<p><code>Symbol(description)</code></p>
+
+<script>
+console.log("%s", Symbol.for("description"));
+console.dirxml("%s", Symbol.for("description"));
+console.trace("%s", Symbol.for("description"));
+console.group("%s", Symbol.for("description"));
+console.groupEnd();
+console.groupCollapsed("%s", Symbol.for("description"));
+console.groupEnd();
+</script>
+</body>
+</html>