summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html')
-rw-r--r--testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html b/testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html
new file mode 100644
index 0000000000..923bde7583
--- /dev/null
+++ b/testing/web-platform/tests/custom-elements/reactions/customized-builtins/HTMLEmbedElement.html
@@ -0,0 +1,35 @@
+<!DOCTYPE html>
+<title>Custom Elements: CEReactions on HTMLEmbedElement interface</title>
+<link rel="author" title="Intel" href="http://www.intel.com">
+<meta name="assert" content="src, type, width, height of
+ HTMLEmbedElement interface must have CEReactions">
+<meta name="help" content="https://html.spec.whatwg.org/#the-embed-element">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="../../resources/custom-elements-helpers.js"></script>
+<script src="../resources/reactions.js"></script>
+
+<script>
+
+testReflectAttribute(
+ 'src', 'src', '/media/movie_5.mp4',
+ '/media/sound_5.mp3', 'src on HTMLEmbedElement', 'embed',
+ HTMLEmbedElement
+);
+testReflectAttribute(
+ 'type', 'type', 'video/webm',
+ 'video/mp4', 'type on HTMLEmbedElement', 'embed',
+ HTMLEmbedElement
+);
+testReflectAttribute(
+ 'width', 'width', '100',
+ '120', 'width on HTMLEmbedElement', 'embed',
+ HTMLEmbedElement
+);
+testReflectAttribute(
+ 'height', 'height', '100',
+ '120', 'height on HTMLEmbedElement', 'embed',
+ HTMLEmbedElement
+);
+
+</script>