summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html')
-rw-r--r--testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html b/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html
new file mode 100644
index 0000000000..7b5dd11a40
--- /dev/null
+++ b/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode-extra.html
@@ -0,0 +1,32 @@
+<!DOCTYPE html>
+<html lang="en-GB">
+<head>
+<meta charset="utf-8"/>
+<title>Big5 decoding (extra)</title>
+<meta name="timeout" content="long">
+<meta name="variant" content="?1-1000">
+<meta name="variant" content="?1001-2000">
+<meta name="variant" content="?2001-last">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/common/subset-tests.js"></script>
+<link rel="author" title="Richard Ishida" href="mailto:ishida@w3.org">
+<link rel="help" href="https://encoding.spec.whatwg.org/#big5">
+<meta name="assert" content="The browser decodes all characters as expected from a file generated by encoding all pointers less than 5024 in the big5 encoding per the encoder steps in the specification.">
+<style>
+ iframe { display:none }
+ form { display:none }
+</style>
+<script src="big5_index.js"></script>
+<script src="big5-decoder.js"></script>
+<script src="../../resources/decode-common.js"></script>
+</head>
+
+<body onload="showNodes(big5Decoder);">
+
+<iframe src="big5_chars_extra.html" name="scriptWindow" id="scrwin"></iframe>
+
+<div id="log"></div>
+
+</body>
+</html>