summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm')
-rw-r--r--testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm b/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm
new file mode 100644
index 0000000000..4e4c3faff9
--- /dev/null
+++ b/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-1.htm
@@ -0,0 +1,23 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: send() with document.domain set: loading documents from original origin after setting document.domain</title>
+ <script src="send-after-setting-document-domain-window-helper.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[2]/ol[1]/li[3]" />
+ </head>
+ <body>
+ <script>
+ run_test(function() {
+ document.domain = document.domain; // this is not a noop, it does actually change the security context
+ var client = new XMLHttpRequest();
+ client.open("GET", "status.py?content=hello", false);
+ client.send(null);
+ assert_equals(client.responseText, "hello");
+ document.domain = document.domain.replace(/^\w+\./, "");
+ client.open("GET", "status.py?content=hello2", false);
+ client.send(null);
+ assert_equals(client.responseText, "hello2");
+ }, "loading documents from original origin after setting document.domain");
+ </script>
+ </body>
+</html>