summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm')
-rw-r--r--testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm b/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm
new file mode 100644
index 0000000000..cd9f0c6bb7
--- /dev/null
+++ b/testing/web-platform/tests/xhr/resources/send-after-setting-document-domain-window-2.htm
@@ -0,0 +1,20 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: send() with document.domain set: loading documents from the origin document.domain was set to should throw</title>
+ <script src="send-after-setting-document-domain-window-helper.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-open()-method" data-tested-assertations="following::ol[1]/li[2]/ol[1]/li[3]" />
+ </head>
+ <body>
+ <script>
+ run_test(function() {
+ document.domain = document.domain.replace(/^\w+\./, "");
+ var client = new XMLHttpRequest();
+ client.open("GET", location.protocol + "//" + document.domain + location.pathname.replace(/[^\/]*$/, "") + "status.py?content=hello3", false);
+ assert_throws_dom("NetworkError", function() {
+ client.send(null);
+ });
+ }, "loading documents from the origin document.domain was set to should throw");
+ </script>
+ </body>
+</html>