summaryrefslogtreecommitdiffstats
path: root/third_party/rust/error-support/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/error-support/Cargo.toml')
-rw-r--r--third_party/rust/error-support/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/error-support/Cargo.toml b/third_party/rust/error-support/Cargo.toml
new file mode 100644
index 0000000000..35d911dd75
--- /dev/null
+++ b/third_party/rust/error-support/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "error-support"
+version = "0.1.0"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+autotests = false
+readme = "README.md"
+license = "MPL-2.0"
+
+[dependencies]
+log = "0.4"
+uniffi = "0.23"
+
+[dependencies.backtrace]
+version = "0.3"
+optional = true
+
+[dependencies.error-support-macros]
+path = "macros"
+
+[dependencies.lazy_static]
+version = "1.4"
+
+[dependencies.parking_lot]
+version = ">=0.11,<=0.12"
+
+[build-dependencies.uniffi]
+version = "0.23"
+features = ["build"]