summaryrefslogtreecommitdiffstats
path: root/toolkit/mozapps/defaultagent/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/mozapps/defaultagent/rust/Cargo.toml')
-rw-r--r--toolkit/mozapps/defaultagent/rust/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/toolkit/mozapps/defaultagent/rust/Cargo.toml b/toolkit/mozapps/defaultagent/rust/Cargo.toml
new file mode 100644
index 0000000000..4bd44a9df8
--- /dev/null
+++ b/toolkit/mozapps/defaultagent/rust/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "defaultagent-static"
+version = "0.1.0"
+authors = ["The Mozilla Install/Update Team <install-update@mozilla.com>"]
+edition = "2018"
+description = "FFI to Rust for use in Firefox's default browser agent."
+repository = "https://github.com/mozilla/defaultagent-static"
+license = "MPL-2.0"
+
+[dependencies]
+log = { version = "0.4", features = ["std"] }
+mozilla-central-workspace-hack = { path = "../../../../build/workspace-hack" }
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+url = "2.1"
+viaduct = "0.1"
+wineventlog = { path = "wineventlog"}
+wio = "0.2"
+winapi = { version = "0.3", features = ["errhandlingapi", "handleapi", "minwindef", "winerror", "wininet", "winuser"] }
+
+[lib]
+crate-type = ["staticlib"]