summaryrefslogtreecommitdiffstats
path: root/libmount/python/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libmount/python/meson.build')
-rw-r--r--libmount/python/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/libmount/python/meson.build b/libmount/python/meson.build
new file mode 100644
index 0000000..59d61d1
--- /dev/null
+++ b/libmount/python/meson.build
@@ -0,0 +1,34 @@
+python_module = import('python')
+
+python = python_module.find_installation(
+ get_option('python'),
+ required : get_option('build-python'),
+ disabler : true)
+build_python = python.found()
+
+pylibmount_sources = '''
+ pylibmount.c
+ pylibmount.h
+ fs.c
+ tab.c
+'''.split()
+
+if LINUX
+ pylibmount_sources += 'context.c'
+endif
+
+python.extension_module(
+ 'pylibmount',
+ pylibmount_sources,
+ include_directories : [dir_include, dir_libmount],
+ subdir : 'libmount',
+ link_with : lib_mount,
+ dependencies : python.dependency(),
+ install : true)
+
+if build_python
+ python.install_sources(
+ '__init__.py',
+ subdir : 'libmount',
+ pure : false)
+endif