summaryrefslogtreecommitdiffstats
path: root/debian/policy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/policy/Makefile')
-rw-r--r--debian/policy/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/policy/Makefile b/debian/policy/Makefile
new file mode 100644
index 0000000..e5d7311
--- /dev/null
+++ b/debian/policy/Makefile
@@ -0,0 +1,23 @@
+
+NULL =
+INSTALL_STUFF = \
+ vim-policy.html/ \
+ vim-policy.txt \
+ $(NULL)
+
+all: html text
+
+html: vim-policy.html/index.html
+text: vim-policy.txt
+
+export LC_ALL=C.UTF-8
+
+vim-policy.html/index.html: vim-policy.xml *.xml
+ docbook2html $< -o $(dir $@)
+vim-policy.txt: vim-policy.xml *.xml
+ docbook2txt $<
+
+clean:
+ $(RM) -rf $(INSTALL_STUFF)
+
+.PHONY: html text