summaryrefslogtreecommitdiffstats
path: root/src/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.kmk')
-rw-r--r--src/Makefile.kmk50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/Makefile.kmk b/src/Makefile.kmk
new file mode 100644
index 00000000..64451bdf
--- /dev/null
+++ b/src/Makefile.kmk
@@ -0,0 +1,50 @@
+# $Id: Makefile.kmk $
+## @file
+# Top-level makefile for the src directory.
+#
+
+#
+# Copyright (C) 2006-2022 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ..
+include $(KBUILD_PATH)/subheader.kmk
+
+include $(PATH_SUB_CURRENT)/bldprogs/Makefile.kmk
+include $(PATH_SUB_CURRENT)/VBox/Makefile.kmk
+include $(PATH_SUB_CURRENT)/libs/Makefile.kmk
+if defined(VBOX_ONLY_EXTPACKS) && !defined(VBOX_ONLY_EXTPACKS_USE_IMPLIBS) && defined(VBOX_WITH_REM)
+ include $(PATH_SUB_CURRENT)/recompiler/Makefile.kmk
+
+else if !defined(VBOX_ONLY_BUILD)
+ # Normal build.
+ if1of ($(KBUILD_TARGET_ARCH), $(VBOX_SUPPORTED_HOST_ARCHS))
+ ifdef VBOX_WITH_REM
+ include $(PATH_SUB_CURRENT)/recompiler/Makefile.kmk
+ endif
+ endif
+ ifneq ($(wildcard $(PATH_SUB_CURRENT)/apps),)
+ include $(PATH_SUB_CURRENT)/apps/Makefile.kmk
+ endif
+endif # !VBOX_ONLY_BUILD
+
+include $(FILE_KBUILD_SUB_FOOTER)
+