summaryrefslogtreecommitdiffstats
path: root/src/VBox/Devices/BiosCommonCode/Makefile.kmk
diff options
context:
space:
mode:
Diffstat (limited to 'src/VBox/Devices/BiosCommonCode/Makefile.kmk')
-rw-r--r--src/VBox/Devices/BiosCommonCode/Makefile.kmk43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/VBox/Devices/BiosCommonCode/Makefile.kmk b/src/VBox/Devices/BiosCommonCode/Makefile.kmk
new file mode 100644
index 00000000..fd61b8a6
--- /dev/null
+++ b/src/VBox/Devices/BiosCommonCode/Makefile.kmk
@@ -0,0 +1,43 @@
+# $Id: Makefile.kmk $
+## @file
+# Sub-Makefile for the New BIOS ROM.
+#
+
+#
+# Copyright (C) 2012-2022 Oracle and/or its affiliates.
+#
+# This file is part of VirtualBox base platform packages, as
+# available from https://www.virtualbox.org.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, in version 3 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, see <https://www.gnu.org/licenses>.
+#
+# SPDX-License-Identifier: GPL-3.0-only
+#
+
+SUB_DEPTH = ../../../..
+include $(KBUILD_PATH)/subheader.kmk
+
+#
+# MakeAlternative - For distros without OpenWatcom.
+#
+BLDPROGS += MakeAlternativeSource
+MakeAlternativeSource_TEMPLATE = VBoxAdvBldProg
+MakeAlternativeSource_DEFS = IN_DIS
+MakeAlternativeSource_SOURCES = MakeAlternativeSource.cpp
+MakeAlternativeSource_LIBS = \
+ $(PATH_STAGE_LIB)/DisasmBldProg$(VBOX_HOSTSUFF_LIB)
+
+
+include $(FILE_KBUILD_SUB_FOOTER)
+