summaryrefslogtreecommitdiffstats
path: root/debian/patches/0002-Don-t-strip-binaries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Don-t-strip-binaries.patch')
-rw-r--r--debian/patches/0002-Don-t-strip-binaries.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/0002-Don-t-strip-binaries.patch b/debian/patches/0002-Don-t-strip-binaries.patch
new file mode 100644
index 0000000..1e6b58f
--- /dev/null
+++ b/debian/patches/0002-Don-t-strip-binaries.patch
@@ -0,0 +1,24 @@
+From: Jeremie Corbier <jeremie+debian@famille-corbier.net>
+Date: Tue, 6 Apr 2010 15:51:06 +0200
+Subject: Don't strip binaries
+
+This patch prevents wide-dhcpv6 build system from stripping built binaries.
+
+Signed-off-by: Jeremie Corbier <jeremie@famille-corbier.net>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a39596f..de25f48 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -103,7 +103,7 @@ $(srcdir)/ianaopts.h: gentab.pl bootp-dhcp-parameters
+
+ install::
+ -mkdir -p $(sbindir) $(mandir)/man5 $(mandir)/man8
+- $(INSTALL_PROGRAM) -s -o $(user) -g $(group) $(TARGET) $(sbindir)
++ $(INSTALL_PROGRAM) -o $(user) -g $(group) $(TARGET) $(sbindir)
+ $(INSTALL_DATA) -o $(user) -g $(group) dhcp6c.8 $(mandir)/man8
+ $(INSTALL_DATA) -o $(user) -g $(group) dhcp6s.8 $(mandir)/man8
+ $(INSTALL_DATA) -o $(user) -g $(group) dhcp6relay.8 $(mandir)/man8