summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:01:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 17:01:42 +0000
commitaa98e388fa3407f703f80c61117237af961f61b3 (patch)
tree28b7e94cee4f96a9a0ea2b482cd279279e7bb713 /configure.ac
parentInitial commit. (diff)
downloadxdg-user-dirs-aa98e388fa3407f703f80c61117237af961f61b3.tar.xz
xdg-user-dirs-aa98e388fa3407f703f80c61117237af961f61b3.zip
Adding upstream version 0.18.upstream/0.18upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac83
1 files changed, 83 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..2cce082
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,83 @@
+AC_INIT(xdg-user-dirs-update.c)
+
+AM_INIT_AUTOMAKE(xdg-user-dirs, 0.18)
+AM_CONFIG_HEADER(config.h)
+
+AM_SANITY_CHECK
+AM_MAINTAINER_MODE
+
+AC_C_CONST
+AC_ISC_POSIX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AM_PROG_MKDIR_P
+AM_ICONV
+
+GETTEXT_PACKAGE=xdg-user-dirs
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [The gettext domain name])
+AC_SUBST(GETTEXT_PACKAGE)
+
+AM_GNU_GETTEXT([external])
+
+dnl ==========================================================================
+dnl Turn on the additional warnings last, so -Werror doesn't affect other tests.
+
+AC_ARG_ENABLE(more-warnings,
+ AS_HELP_STRING([--enable-more-warnings],[Maximum compiler warnings]),
+set_more_warnings="$enableval",[
+if test -f $srcdir/CVSVERSION; then
+ is_cvs_version=true
+ set_more_warnings=yes
+else
+ set_more_warnings=no
+fi
+])
+AC_MSG_CHECKING(for more warnings, including -Werror)
+if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
+ AC_MSG_RESULT(yes)
+ CFLAGS="\
+ -Wall \
+ -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
+ -Wnested-externs -Wpointer-arith \
+ -Wcast-align -Wsign-compare \
+ -Werror \
+ $CFLAGS"
+
+ for option in -Wno-strict-aliasing -Wno-sign-compare; do
+ SAVE_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $option"
+ AC_MSG_CHECKING([whether gcc understands $option])
+ AC_TRY_COMPILE([], [],
+ has_option=yes,
+ has_option=no,)
+ if test $has_option = no; then
+ CFLAGS="$SAVE_CFLAGS"
+ fi
+ AC_MSG_RESULT($has_option)
+ unset has_option
+ unset SAVE_CFLAGS
+ done
+ unset option
+else
+ AC_MSG_RESULT(no)
+fi
+
+AC_ARG_ENABLE(documentation,
+ AC_HELP_STRING([--enable-documentation],
+ [build documentation]),,
+ enable_documentation=yes)
+if test x$enable_documentation = xyes; then
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ if test x$XSLTPROC = x; then
+ AC_MSG_ERROR([xsltproc is required to build documentation])
+ fi
+fi
+AM_CONDITIONAL(BUILD_DOCUMENTATION, test x$enable_documentation = xyes)
+
+AC_OUTPUT([ po/Makefile.in
+Makefile
+man/Makefile
+])