summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cc861b0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs
+
+%:
+ dh $@ --with gnome
+
+override_dh_autoreconf:
+ dh_autoreconf
+ cp /usr/share/automake-*/mkinstalldirs .
+
+override_dh_auto_build:
+ dh_auto_build
+ $(MAKE) -C po update-gmo
+
+override_dh_clean:
+ rm -f po/*.gmo
+ dh_clean