summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:14:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:14:57 +0000
commit9e007c9b39bc075b74cbd60827c0f314356b607a (patch)
tree8600888a0c2a2865ab45a6d84cd3f67f2454128e
parentUsing https in GPL URLs. (diff)
downloadprogress-linux-metapackages-9e007c9b39bc075b74cbd60827c0f314356b607a.tar.xz
progress-linux-metapackages-9e007c9b39bc075b74cbd60827c0f314356b607a.zip
Using rst to generate manpage.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--manpages/Makefile59
-rw-r--r--manpages/manpages.in19
-rw-r--r--manpages/progress-linux-metapackages.743
-rw-r--r--manpages/progress-linux-metapackages.7.rst80
4 files changed, 158 insertions, 43 deletions
diff --git a/manpages/Makefile b/manpages/Makefile
new file mode 100644
index 0000000..3ddbdf1
--- /dev/null
+++ b/manpages/Makefile
@@ -0,0 +1,59 @@
+# Progress Linux metapackages
+
+# Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: manpages
+
+rebuild: clean build
+
+manpages: manpages.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp manpages.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} progress-linux-metapackages |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
+
+clean:
+ rm -f *.[0-9]
+
+.PHONY: all clean build rebuild manpages
diff --git a/manpages/manpages.in b/manpages/manpages.in
new file mode 100644
index 0000000..b602b75
--- /dev/null
+++ b/manpages/manpages.in
@@ -0,0 +1,19 @@
+.\" Progress Linux metapackages
+
+.\" Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+.\"
+.\" SPDX-License-Identifier: GPL-3.0+
+.\"
+.\" This program is free software: you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation, either version 3 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
+.\"
diff --git a/manpages/progress-linux-metapackages.7 b/manpages/progress-linux-metapackages.7
deleted file mode 100644
index 1b30e57..0000000
--- a/manpages/progress-linux-metapackages.7
+++ /dev/null
@@ -1,43 +0,0 @@
-.\" Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
-.\"
-.\" SPDX-License-Identifier: GPL-3.0+
-.\"
-.\" This program is free software: you can redistribute it and/or modify
-.\" it under the terms of the GNU General Public License as published by
-.\" the Free Software Foundation, either version 3 of the License, or
-.\" (at your option) any later version.
-.\"
-.\" This program is distributed in the hope that it will be useful,
-.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
-.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-.\" GNU General Public License for more details.
-.\"
-.\" You should have received a copy of the GNU General Public License
-.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-.TH PROGRESS\-LINUX\-METAPACKAGES 7 2021\-01\-01 20210101 "Progress Linux Metapackages"
-
-.SH NAME
-\fBProgress Linux Metapackages\fR \- Package selection for Progress Linux systems
-
-.SH DESCRIPTION
-\fBProgress Linux\fR is a Debian derivative distribution focused on system integration.
-The following metapackages are available:
-
-.IP "\fBbase\-system\fR" 4
-The Progress Linux Base System includes packages that provide a reasonably
-small but not too limited character-mode system.
-
-.IP "\fBcontainer\-server\fR" 4
-The Progress Linux Container Server is a complete system configured as a server
-for systemd\-nspawn based containers.
-
-.IP "\fBgnome\-desktop\fR" 4
-The Progress Linux GNOME Desktop is a complete system configured as a desktop
-for power users.
-
-.SH HOMEPAGE
-More information about the Progress Linux project can be found on the homepage at <\fIhttps://progress-linux.org\fR>.
-
-.SH AUTHOR
-This manpage was written by Daniel Baumann <\fIdaniel.baumann@progress-linux.org\fR>.
diff --git a/manpages/progress-linux-metapackages.7.rst b/manpages/progress-linux-metapackages.7.rst
new file mode 100644
index 0000000..6eb8603
--- /dev/null
+++ b/manpages/progress-linux-metapackages.7.rst
@@ -0,0 +1,80 @@
+.. Progress Linux metapackages
+
+.. Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+..
+.. SPDX-License-Identifier: GPL-3.0+
+..
+.. This program is free software: you can redistribute it and/or modify
+.. it under the terms of the GNU General Public License as published by
+.. the Free Software Foundation, either version 3 of the License, or
+.. (at your option) any later version.
+..
+.. This program is distributed in the hope that it will be useful,
+.. but WITHOUT ANY WARRANTY; without even the implied warranty of
+.. MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.. GNU General Public License for more details.
+..
+.. You should have received a copy of the GNU General Public License
+.. along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+===========================
+progress-linux-metapackages
+===========================
+
+------------------------------------
+Package selection for Progress Linux
+------------------------------------
+
+:manual section: 7
+:manual group: Progress Linux
+
+Description
+===========
+
+Progress Linux is a Debian derivative distribution focused on system
+integration.
+
+The following main metapackages are available:
+
+progress-linux-base-system
+--------------------------
+
+| The Progress Linux Base System includes packages that provide a reasonably
+| small but not too limited character-mode system.
+
+progress-linux-container-server
+-------------------------------
+
+| The Progress Linux Container Server is a complete system configured as a
+| server for systemd-nspawn based containers.
+
+progress-linux-gnome-desktop
+----------------------------
+
+| The Progress Linux GNOME Desktop is a complete system configured as a desktop
+| for power users.
+
+Development
+===========
+
+Bug reports, feature requests, help, patches, support and everything else are
+welcome on the Progress Linux Maintainers Mailing List
+(https://lists.progress-linux.org/listinfo/maintainers).
+
+Please base patches against the 'next' Git branch using common sense
+(https://www.kernel.org/doc/Documentation/SubmittingPatches).
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System
+(https://bugs.debian.org).
+
+Homepage
+========
+
+More information about Progress Linux can be found on the homepage
+(https://progress-linux.org).
+
+Authors
+=======
+
+progress-linux-metapackages were written by Daniel Baumann
+<daniel.baumann@progress-linux.org> and others.