summaryrefslogtreecommitdiffstats
path: root/manpages/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:14:57 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-10-02 10:14:57 +0000
commit23b1eccaf390eeac5a504b264cf8cd5cf126727f (patch)
tree07d616779f5a670c03e69b05224e479ee697543a /manpages/Makefile
parentUsing rst to generate manpage. (diff)
downloadprogress-linux-metapackages-23b1eccaf390eeac5a504b264cf8cd5cf126727f.tar.xz
progress-linux-metapackages-23b1eccaf390eeac5a504b264cf8cd5cf126727f.zip
Consistently renaming manpages files and sub-directory to man.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'manpages/Makefile')
-rw-r--r--manpages/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/manpages/Makefile b/manpages/Makefile
deleted file mode 100644
index 3ddbdf1..0000000
--- a/manpages/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# Progress Linux metapackages
-
-# Copyright (C) 2010-2021 Daniel Baumann <daniel.baumann@progress-linux.org>
-#
-# SPDX-License-Identifier: GPL-3.0+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-# Depends: python3-docutils
-
-RST2MAN = rst2man \
- --no-datestamp \
- --no-generator \
- --strict \
- --strip-comments \
- --tab-width=4 \
- --verbose
-
-VERSION := $(shell cat ../VERSION.txt)
-
-SHELL := sh -e
-
-all: build
-
-build: manpages
-
-rebuild: clean build
-
-manpages: manpages.in *.rst
- @echo -n "Creating manpages... "
-
- @for FILE in *.rst; \
- do \
- cp manpages.in $$(basename $${FILE} .rst); \
- $(RST2MAN) $${FILE} | \
- sed -e '/^.\\" Man page generated/d' \
- -e '/^.\\" Generated by/d' \
- -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} progress-linux-metapackages |" \
- >> $$(basename $${FILE} .rst); \
- echo -n "."; \
- done
-
- @echo " done."
-
-clean:
- rm -f *.[0-9]
-
-.PHONY: all clean build rebuild manpages