summaryrefslogtreecommitdiffstats
path: root/bin/git-debian-add
diff options
context:
space:
mode:
Diffstat (limited to 'bin/git-debian-add')
-rwxr-xr-xbin/git-debian-add7
1 files changed, 7 insertions, 0 deletions
diff --git a/bin/git-debian-add b/bin/git-debian-add
index 06e25b9..a14b9e5 100755
--- a/bin/git-debian-add
+++ b/bin/git-debian-add
@@ -20,6 +20,13 @@ HASH="${2}"
chmod 0755 debian/rules
+if [ -e .gitattributes ]
+then
+ ( cat .gitattributes | grep -v 'filter=lfs' > .gitattributes.tmp ) || true
+ rm -f .gitattributes
+ mv .gitattributes.tmp .gitattributes
+fi
+
git add -A -f
git commit -a -s -m "Adding ${MODE} version ${VERSION}." ${GIT_OPTIONS}
git-${MODE}-tag ${VERSION} ${HASH}