summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 09:24:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 09:24:45 +0000
commitb88b57aff93c95ae07f8a2f05a6a577b39cb1f1f (patch)
treea8c2cbdeefe4aba4936c128ebfd4cb600da23dc1 /Makefile
parentInitial commit. (diff)
downloadaio-eapi-b88b57aff93c95ae07f8a2f05a6a577b39cb1f1f.tar.xz
aio-eapi-b88b57aff93c95ae07f8a2f05a6a577b39cb1f1f.zip
Adding upstream version 0.6.3.upstream/0.6.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..3838965
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,26 @@
+.PHONY: setup.py requirements.txt
+
+DIST_BASENAME := $(shell poetry version | tr ' ' '-')
+
+all: precheck
+
+.PHONY: prechck
+precheck:
+ black . && \
+ pre-commit run -a && \
+ interrogate -c pyproject.toml
+
+package: setup.py requirements.txt
+
+setup.py:
+ poetry build && \
+ tar --strip-components=1 -xvf dist/$(DIST_BASENAME).tar.gz '*/setup.py'
+
+requirements.txt:
+ poetry export --without-hashes > requirements.txt
+
+clean:
+ rm -rf dist *.egg-info .pytest_cache
+ rm -f requirements.txt setup.py
+ rm -f poetry.lock
+ find . -name '__pycache__' | xargs rm -rf