summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..3838965
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,26 @@
+.PHONY: setup.py requirements.txt
+
+DIST_BASENAME := $(shell poetry version | tr ' ' '-')
+
+all: precheck
+
+.PHONY: prechck
+precheck:
+ black . && \
+ pre-commit run -a && \
+ interrogate -c pyproject.toml
+
+package: setup.py requirements.txt
+
+setup.py:
+ poetry build && \
+ tar --strip-components=1 -xvf dist/$(DIST_BASENAME).tar.gz '*/setup.py'
+
+requirements.txt:
+ poetry export --without-hashes > requirements.txt
+
+clean:
+ rm -rf dist *.egg-info .pytest_cache
+ rm -f requirements.txt setup.py
+ rm -f poetry.lock
+ find . -name '__pycache__' | xargs rm -rf