summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..4036f19
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,37 @@
+[tool.poetry]
+name = "aio-eapi"
+version = "0.6.3"
+description = "Arista EOS API asyncio client"
+readme = "README.md"
+authors = ["Jeremy Schulman"]
+packages = [
+ { include = 'aioeapi' },
+]
+
+[tool.poetry.dependencies]
+python = ">=3.8"
+httpx = "^0.23.3"
+
+
+[tool.poetry.dev-dependencies]
+ pytest = "*"
+ invoke = "*"
+ black = "*"
+ flake8 = "*"
+ pytest-cov = "*"
+ pytest-asyncio = "*"
+ pre-commit = "*"
+ interrogate = "*"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.interrogate]
+ fail-under = 0
+ verbose = 1
+ color = true
+ ignore-module = true
+ exclude = ["examples", "build", "venv"]
+
+