summaryrefslogtreecommitdiffstats
path: root/.vscode/settings.json
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-28 06:11:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-28 06:11:39 +0000
commit1fd6a618b60d7168fd8f37585d5d39d22d775afd (patch)
treefbc6d0c213b8acdd0a31deafe5c5fc0d05a3a312 /.vscode/settings.json
parentInitial commit. (diff)
downloadanta-1fd6a618b60d7168fd8f37585d5d39d22d775afd.tar.xz
anta-1fd6a618b60d7168fd8f37585d5d39d22d775afd.zip
Adding upstream version 0.13.0.upstream/0.13.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.vscode/settings.json')
-rw-r--r--.vscode/settings.json30
1 files changed, 30 insertions, 0 deletions
diff --git a/.vscode/settings.json b/.vscode/settings.json
new file mode 100644
index 0000000..ff14cc1
--- /dev/null
+++ b/.vscode/settings.json
@@ -0,0 +1,30 @@
+{
+ "black-formatter.importStrategy": "fromEnvironment",
+ "pylint.importStrategy": "fromEnvironment",
+ "pylint.args": [
+ "--rcfile=pylintrc"
+ ],
+ "flake8.importStrategy": "fromEnvironment",
+ "flake8.args": [
+ "--config=/dev/null",
+ "--max-line-length=165"
+ ],
+ "mypy-type-checker.importStrategy": "fromEnvironment",
+ "mypy-type-checker.args": [
+ "--config-file=pyproject.toml"
+ ],
+ "pylint.severity": {
+ "refactor": "Warning"
+ },
+ "pylint.args": [
+ "--load-plugins pylint_pydantic",
+ "--rcfile=pylintrc"
+ ],
+ "python.testing.pytestArgs": [
+ "tests"
+ ],
+ "python.testing.unittestEnabled": false,
+ "python.testing.pytestEnabled": true,
+ "isort.importStrategy": "fromEnvironment",
+ "isort.check": true,
+} \ No newline at end of file