summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml51
1 files changed, 21 insertions, 30 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index d2a26a4..e933a9d 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -40,51 +40,42 @@ repos:
- --comment-style
- '<!--| ~| -->'
- - repo: https://github.com/pycqa/isort
- rev: 5.13.2
+ - repo: https://github.com/astral-sh/ruff-pre-commit
+ rev: v0.3.5
hooks:
- - id: isort
- name: Check for changes when running isort on all python files
-
- - repo: https://github.com/psf/black
- rev: 24.1.1
- hooks:
- - id: black
- name: Check for changes when running Black on all python files
-
- - repo: https://github.com/pycqa/flake8
- rev: 7.0.0
- hooks:
- - id: flake8
- name: Check for PEP8 error on Python files
- args:
- - --config=/dev/null
- - --max-line-length=165
+ - id: ruff
+ name: Run Ruff linter
+ args: [ --fix ]
+ - id: ruff-format
+ name: Run Ruff formatter
- repo: local # as per https://pylint.pycqa.org/en/latest/user_guide/installation/pre-commit-integration.html
hooks:
- id: pylint
entry: pylint
language: python
- name: Check for Linting error on Python files
+ name: Check code style with pylint
description: This hook runs pylint.
types: [python]
args:
- - -rn # Only display messages
- - -sn # Don't display the score
- - --rcfile=pylintrc # Link to config file
+ - -rn # Only display messages
+ - -sn # Don't display the score
+ - --rcfile=pyproject.toml # Link to config file
- # Prepare to turn on ruff
- # - repo: https://github.com/astral-sh/ruff-pre-commit
- # # Ruff version.
- # rev: v0.0.280
- # hooks:
- # - id: ruff
+ - repo: https://github.com/codespell-project/codespell
+ rev: v2.2.6
+ hooks:
+ - id: codespell
+ name: Checks for common misspellings in text files.
+ entry: codespell
+ language: python
+ types: [text]
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.7.1
+ rev: v1.9.0
hooks:
- id: mypy
+ name: Check typing with mypy
args:
- --config-file=pyproject.toml
additional_dependencies: