summaryrefslogtreecommitdiffstats
path: root/.vscode/settings.json
diff options
context:
space:
mode:
Diffstat (limited to '.vscode/settings.json')
-rw-r--r--.vscode/settings.json18
1 files changed, 4 insertions, 14 deletions
diff --git a/.vscode/settings.json b/.vscode/settings.json
index ff14cc1..8428c00 100644
--- a/.vscode/settings.json
+++ b/.vscode/settings.json
@@ -1,14 +1,8 @@
{
- "black-formatter.importStrategy": "fromEnvironment",
+ "ruff.enable": true,
+ "python.testing.unittestEnabled": false,
+ "python.testing.pytestEnabled": true,
"pylint.importStrategy": "fromEnvironment",
- "pylint.args": [
- "--rcfile=pylintrc"
- ],
- "flake8.importStrategy": "fromEnvironment",
- "flake8.args": [
- "--config=/dev/null",
- "--max-line-length=165"
- ],
"mypy-type-checker.importStrategy": "fromEnvironment",
"mypy-type-checker.args": [
"--config-file=pyproject.toml"
@@ -17,14 +11,10 @@
"refactor": "Warning"
},
"pylint.args": [
- "--load-plugins pylint_pydantic",
+ "--load-plugins", "pylint_pydantic",
"--rcfile=pylintrc"
],
"python.testing.pytestArgs": [
"tests"
],
- "python.testing.unittestEnabled": false,
- "python.testing.pytestEnabled": true,
- "isort.importStrategy": "fromEnvironment",
- "isort.check": true,
} \ No newline at end of file