summaryrefslogtreecommitdiffstats
path: root/docs/requirements-and-installation.md
diff options
context:
space:
mode:
Diffstat (limited to 'docs/requirements-and-installation.md')
-rw-r--r--docs/requirements-and-installation.md40
1 files changed, 36 insertions, 4 deletions
diff --git a/docs/requirements-and-installation.md b/docs/requirements-and-installation.md
index b3107a6..75560d3 100644
--- a/docs/requirements-and-installation.md
+++ b/docs/requirements-and-installation.md
@@ -22,25 +22,57 @@ This installation will deploy tests collection, scripts and all their Python req
The ANTA package and the cli require some packages that are not part of the Python standard library. They are indicated in the [pyproject.toml](https://github.com/arista-netdevops-community/anta/blob/main/pyproject.toml) file, under dependencies.
-### Install from Pypi server
+### Install library from Pypi server
```bash
pip install anta
```
+!!! Warning
+
+ * This command alone **will not** install the ANTA CLI requirements.
+ * When using ANTA mode in [AVD](https://avd.arista.com) `eos_validate` role, (currently in preview), ensure you install the documented supported ANTA version for your AVD version.</br>
+ The latest documented version can be found at: https://avd.arista.com/stable/roles/eos_validate_state/ANTA-Preview.html
+
+### Install ANTA CLI as an application with `pipx`
+
+[`pipx`](https://pipx.pypa.io/stable/) is a tool to install and run python applications in isolated environments. If you plan to use ANTA only as a CLI tool you can use `pipx` to install it. `pipx` installs ANTA in an isolated python environment and makes it available globally.
+
+```
+pipx install anta[cli]
+```
+
+!!! Info
+
+ Please take the time to read through the installation instructions of `pipx` before getting started.
+
+
+### Install CLI from Pypi server
+
+Alternatively, pip install with `cli` extra is enough to install the ANTA CLI.
+
+```bash
+pip install anta[cli]
+```
+
### Install ANTA from github
```bash
pip install git+https://github.com/arista-netdevops-community/anta.git
+pip install git+https://github.com/arista-netdevops-community/anta.git#egg=anta[cli]
# You can even specify the branch, tag or commit:
pip install git+https://github.com/arista-netdevops-community/anta.git@<cool-feature-branch>
+pip install git+https://github.com/arista-netdevops-community/anta.git@<cool-feature-branch>#egg=anta[cli]
+
pip install git+https://github.com/arista-netdevops-community/anta.git@<cool-tag>
+pip install git+https://github.com/arista-netdevops-community/anta.git@<cool-tag>#egg=anta[cli]
+
pip install git+https://github.com/arista-netdevops-community/anta.git@<more-or-less-cool-hash>
+pip install git+https://github.com/arista-netdevops-community/anta.git@<more-or-less-cool-hash>#egg=anta[cli]
```
-
### Check installation
After installing ANTA, verify the installation with the following commands:
@@ -61,12 +93,12 @@ which anta
```bash
# Check ANTA version
anta --version
-anta, version v0.14.0
+anta, version v0.15.0
```
## EOS Requirements
-To get ANTA working, the targeted Arista EOS devices must have the following configuration (assuming you connect to the device using Management interface in MGMT VRF):
+To get ANTA working, the targeted Arista EOS devices must have eAPI enabled. They need to use the following configuration (assuming you connect to the device using Management interface in MGMT VRF):
```eos
configure