summaryrefslogtreecommitdiffstats
path: root/man
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-10-08 09:25:49 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2021-10-08 11:50:59 +0000
commit8afaf687631cfe490e171f8d53e1ff72e4e288a8 (patch)
tree19cec35eca04bfd74948aec8610fe8a59612106b /man
parentReleasing debian version 20210101-2. (diff)
downloadbfh-metapackages-8afaf687631cfe490e171f8d53e1ff72e4e288a8.tar.xz
bfh-metapackages-8afaf687631cfe490e171f8d53e1ff72e4e288a8.zip
Merging upstream version 20211008.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'man')
-rw-r--r--man/Makefile59
-rw-r--r--man/bfh-metapackages.7.rst81
-rw-r--r--man/man.in19
3 files changed, 159 insertions, 0 deletions
diff --git a/man/Makefile b/man/Makefile
new file mode 100644
index 0000000..03fd019
--- /dev/null
+++ b/man/Makefile
@@ -0,0 +1,59 @@
+# BFH metapackages
+
+# Copyright (C) 2013-2021 Daniel Baumann <daniel@debian.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: man
+
+rebuild: clean build
+
+man: man.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp man.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} compute-tools |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
+
+clean:
+ rm -f *.[0-9]
+
+.PHONY: all clean build rebuild man
diff --git a/man/bfh-metapackages.7.rst b/man/bfh-metapackages.7.rst
new file mode 100644
index 0000000..5c2ebb6
--- /dev/null
+++ b/man/bfh-metapackages.7.rst
@@ -0,0 +1,81 @@
+.. BFH metapackages
+
+.. Copyright (C) 2013-2021 Daniel Baumann <daniel@debian.org>
+..
+.. SPDX-License-Identifier: GPL-3.0+
+..
+.. This program is free software: you can redistribute it and/or modify
+.. it under the terms of the GNU General Public License as published by
+.. the Free Software Foundation, either version 3 of the License, or
+.. (at your option) any later version.
+..
+.. This program is distributed in the hope that it will be useful,
+.. but WITHOUT ANY WARRANTY; without even the implied warranty of
+.. MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.. GNU General Public License for more details.
+..
+.. You should have received a copy of the GNU General Public License
+.. along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+================
+bfh-metapackages
+================
+
+---------------------------------------------------------
+Package selection for Bern University of Applied Sciences
+---------------------------------------------------------
+
+:manual section: 7
+:manual group: BFH
+
+Description
+===========
+
+Bern University of Applied Sciences (BFH) provides Debian-based images and
+systems to its users and everyone else interested in the form of a Debian
+Derrivative.
+
+The following main metapackages are available:
+
+bfh-base-system
+---------------
+
+| The BFH Base System includes packages that provide a reasonably small but not
+| too limited character-mode system.
+
+bfh-container-server
+--------------------
+
+| The BFH Container Server is a complete system configured as a server for
+| systemd-nspawn based containers.
+
+bfh-gnome-desktop
+-----------------
+
+| The BFH GNOME Desktop is a complete system configured as a desktop for power
+| users.
+
+
+Development
+===========
+
+Bug reports, feature requests, help, patches, support and everything else are
+welcome on the BFH Linux Users Mailing List
+(https://lists.bfh.science/listinfo/bfh-linux-users/listinfo/software).
+
+Please base patches against the 'next' Git branch using common sense
+(https://www.kernel.org/doc/Documentation/SubmittingPatches).
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System
+(https://bugs.debian.org).
+
+Homepage
+========
+
+More information about BFH and Team Linux & Infrastructure Services can be found
+on the homepage (https://bfh.science).
+
+Authors
+=======
+
+bfh-metapackages were written by Daniel Baumann <daniel@debian.org> and others.
diff --git a/man/man.in b/man/man.in
new file mode 100644
index 0000000..70e22db
--- /dev/null
+++ b/man/man.in
@@ -0,0 +1,19 @@
+.\" BFH metapackages
+
+.\" Copyright (C) 2013-2021 Daniel Baumann <daniel@debian.org>
+.\"
+.\" SPDX-License-Identifier: GPL-3.0+
+.\"
+.\" This program is free software: you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation, either version 3 of the License, or
+.\" (at your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful,
+.\" but WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program. If not, see <https://www.gnu.org/licenses/>.
+.\"