summaryrefslogtreecommitdiffstats
path: root/.coveragerc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-24 23:39:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-24 23:39:30 +0000
commitcf4143c075460101d46e4f1b28ad42c89cdf008b (patch)
tree23aea1402329cd367a6ee77c19bab26b0c8fd081 /.coveragerc
parentInitial commit. (diff)
downloadcfgv-cf4143c075460101d46e4f1b28ad42c89cdf008b.tar.xz
cfgv-cf4143c075460101d46e4f1b28ad42c89cdf008b.zip
Adding upstream version 3.1.0.upstream/3.1.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.coveragerc')
-rw-r--r--.coveragerc33
1 files changed, 33 insertions, 0 deletions
diff --git a/.coveragerc b/.coveragerc
new file mode 100644
index 0000000..0bada6e
--- /dev/null
+++ b/.coveragerc
@@ -0,0 +1,33 @@
+[run]
+branch = True
+source =
+ .
+omit =
+ .tox/*
+ /usr/*
+ setup.py
+ # Don't complain if non-runnable code isn't run
+ */__main__.py
+
+[report]
+show_missing = True
+skip_covered = True
+exclude_lines =
+ # Have to re-enable the standard pragma
+ \#\s*pragma: no cover
+ # We optionally substitute this
+ ${COVERAGE_IGNORE_WINDOWS}
+
+ # Don't complain if tests don't hit defensive assertion code:
+ ^\s*raise AssertionError\b
+ ^\s*raise NotImplementedError\b
+ ^\s*return NotImplemented\b
+ ^\s*raise$
+
+ # Don't complain if non-runnable code isn't run:
+ ^if __name__ == ['"]__main__['"]:$
+
+[html]
+directory = coverage-html
+
+# vim:ft=dosini