summaryrefslogtreecommitdiffstats
path: root/.coveragerc
diff options
context:
space:
mode:
Diffstat (limited to '.coveragerc')
-rw-r--r--.coveragerc33
1 files changed, 0 insertions, 33 deletions
diff --git a/.coveragerc b/.coveragerc
deleted file mode 100644
index 0bada6e..0000000
--- a/.coveragerc
+++ /dev/null
@@ -1,33 +0,0 @@
-[run]
-branch = True
-source =
- .
-omit =
- .tox/*
- /usr/*
- setup.py
- # Don't complain if non-runnable code isn't run
- */__main__.py
-
-[report]
-show_missing = True
-skip_covered = True
-exclude_lines =
- # Have to re-enable the standard pragma
- \#\s*pragma: no cover
- # We optionally substitute this
- ${COVERAGE_IGNORE_WINDOWS}
-
- # Don't complain if tests don't hit defensive assertion code:
- ^\s*raise AssertionError\b
- ^\s*raise NotImplementedError\b
- ^\s*return NotImplemented\b
- ^\s*raise$
-
- # Don't complain if non-runnable code isn't run:
- ^if __name__ == ['"]__main__['"]:$
-
-[html]
-directory = coverage-html
-
-# vim:ft=dosini