summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-23 11:50:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-23 12:32:38 +0000
commitdf80b649f06e3b48e4a3f0d74d16b39eea32e6e4 (patch)
tree6c6c0f6bbde7ccdc1139f1b477440d2927964b31
parentRemoving glibc-2.30.patch, included upstream. (diff)
downloadck-df80b649f06e3b48e4a3f0d74d16b39eea32e6e4.tar.xz
ck-df80b649f06e3b48e4a3f0d74d16b39eea32e6e4.zip
Streamlining rules file.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules39
1 files changed, 15 insertions, 24 deletions
diff --git a/debian/rules b/debian/rules
index 468baa9..ee6a3be 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,31 +1,22 @@
#!/usr/bin/make -f
-PLATFORM :=
-$(call lazy,DEB_HOST_ARCH,$$(shell dpkg-architecture -qDEB_HOST_ARCH))
-ifneq (,$(findstring armhf,$(DEB_HOST_ARCH)))
- PLATFORM += --platform=armv7l
-endif
-
-override_dh_auto_configure:
- ./configure \
- --includedir=/usr/include \
- --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --cores=2 \
- --disable-sse \
- $(PLATFORM)
+include /usr/share/dpkg/architecture.mk
-override_dh_auto_test:
- make -j1 check
+ifeq ($(DEB_BUILD_ARCH),armel)
+ PLATFORM = --platform=armv7l
+endif
%:
- dh $@
-
-# The build target must not be empty. Sadly because of how make
-# works, we have do duplicate the target in this case.
-build:
- dh $@
+ dh ${@}
-.PHONY: build
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --prefix=/usr \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --includedir=/usr/include \
+ --mandir=/usr/share/man \
+ --cores=2 \
+ --disable-sse $(PLATFORM)
+override_dh_auto_test:
+ $(MAKE) -j1 check